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What This Manual Covers 
The NeuroPort Biopotential Signal Processing System (NeuroPort System) is designed to 
record and process neural signals from up to 512 surface or penetrating electrodes in addition 
to auxiliary analog signals and digital experimental events. The system can acquire a variety of 
biopotential signal types including electrocorticography, electroencephalography, and 
electromyography. The system can perform real-time signal processing algorithms on neural 
signals, including noise cancellation, digital filtering, simultaneous extraction of spike and field 
potentials, and manual and automatic online spike sorting. 

The NeuroPort Biopotential Signal Processing System is not a monitoring system. No 
physiological alarms are provided. The acquisition and display of biopotential signals is for the 
interpretation and use of the clinician. 

Intended Use/Indications for Use 
The NeuroPort Biopotential Signal Processing System supports recording, processing, and 
display of biopotential signals from user-supplied electrodes. Biopotential signals include:  
Electrocorticography (ECoG), electroencephalography (EEG), electromyography (EMG), 
electrocardiography (ECG), electrooculography (EOC) action potentials (AP), and evoked 
potentials (EP). 
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Contraindications, Warnings, and 
Precautions 

Contraindication 

• The NeuroPort System is a recording system and should not be used in 
applications involving stimulation.  

Warnings 

• Read this entire manual prior to using the device. 
• A thorough understanding of the technical principles and risks associated with 

electrophysiological recording is necessary before using this product. 
• Completion of the Blackrock Microsystems user training program is 

recommended prior to the use of the NeuroPort System.  
• Always operate the NeuroPort System in a clean environment.  
• Only connect NeuroPort System components to properly tested, grounded and 

dedicated AC outlets using only the Blackrock provided power cable to reduce 
the risk of electrical shock or malfunction of product. Do not use an adapter for 
ungrounded wall outlets.  

• Do not connect the NeuroPort System to an outlet controlled by a wall switch, 
multiple socket-outlet or extension cord to avoid fires or other electrical hazards. 

• Do not use the NeuroPort System in the presence of flammable anesthetic 
agents. 

• Do not use the NeuroPort System for any use other than its listed intended use. 
• Avoid strong static discharges from sources like televisions or computer monitors 

because it can damage the electrical components of the system. 
• Keep the NeuroPort System away from liquids. Contact with water, shower 

spray, or wet surfaces can lead to the patient receiving an electrical shock. 
• Connection of external instruments may compromise electrical safety compliance 

with IEC 60601-1. 
• The NeuroPort System should be disconnected from any electrodes during 

cardiac defibrillation. 
• The conductive parts of electrodes and their connectors, including neural 

electrodes, should not contact other conductive parts including earth. 
• Place the NeuroPort system in a secure location. 
• Avoid tripping on cords connected to the NeuroPort system. 
• Repair or maintenance is not allowed during equipment operation. 
• Only plug in Blackrock approved equipment into the NeuroPort system. 
• Do not connect the computer hosting the Central software to the internet. 
• Disabling firewalls and antivirus software can leave your system vulnerable to 

cyber attacks. 
• Do not touch any exposed electrical conductors or use damaged Data Cables 

when using the Digital Hub 
• Only connect headstages to the Digital Hub. 
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Precautions 

• Follow the restrictions of use for third party electrodes or arrays. 
• Third party recording or control systems connecting to the NeuroPort System and 

components must be electrically isolated for subject safety. 
• Note that the fiber-optic cable is very delicate. Do not bend it (bend radius of 5.0 

cm) or crush it. 
• Inspect the NeuroPort System and cables prior to use for damage. If damaged, 

do not use. 
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Symbols 

ISO 15223-1:2016 Medical Devices – Symbols to Be Used with Medical Device Labels, 

Labeling, and Information to Be Supplied 

 

Reference Symbol Title Meaning 

5.1.1 

 

Manufacturer Indicates the medical device 

manufacturer. 

5.1.3 

 

Date of 

Manufacture 

Indicates date of manufacture 

and is accompanied by a 

date. 

5.1.4 

 

Use-by Date Indicates the date after which 

the medical device is not to 

be used. 

5.1.5 

 

Batch Code Indicates the manufacturer’s 

batch code so that the batch 

or lot can be identified. 

5.1.6  Catalog Number Indicates the manufacturer’s 

catalog number so that the 

device may be identified. For 

Blackrock Microsystems it is 

called the Part Number (PN). 

5.1.7  Serial Number Indicates the manufacturer’s 

serial number so that a 

specific medical device can 

be identified. 

5.2.3  Sterilized Using 

Ethylene Oxide 

Indicates that the device has 

been sterilized using ethylene 

oxide. 
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ISO 15223-1:2016 Medical Devices – Symbols to Be Used with Medical Device Labels, 

Labeling, and Information to Be Supplied 

Reference Symbol Title Meaning 

5.2.6 

 

Do Not 

Resterilize 

Indicates a medical device 

that is not to be resterilized. 

 

 

5.2.7 

 

Non-Sterile To indicate that the device 

that is normally provided 

sterile in the same or similar 

packaging has not been 

sterilized. 

5.2.8 

 

Do Not Use if 

Package is 

Damaged 

Indicates that a medical 

device should not be used if 

the package has been 

damaged or opened.  

5.4.2 

 

Do Not Reuse Indicates a medical device 

that is intended for one use, 

or for use on a single patient 

during a single procedure. 

5.4.3 

 

Consult 

Instructions for 

Use 

Indicates the need for the 

user to consult the 

instructions for use, which 

you are currently reading. 

5.4.4  Caution Indicates the need for the 

user to consult the 

instructions for use for 

important cautionary 

information such as warning 

and precautions that cannot, 

for a variety of reasons, be 

presented on the medical 

device itself. 
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IEC 60601-1, Edition 3.1 Medical Electrical Equipment – Part 1: General Requirements for 

Basic Safety and Essential Performance  

Reference Symbol Title Meaning 

ISO 7010-M002  Follow 

Instructions for 

Use 

Indicates the need for the user to 

consult the instructions for use for 

important cautionary information 

such as warning and precautions 

that cannot, for a variety of 

reasons, be presented on the 

medical device itself. 

 

 

 

 

 

 

 

IEC 60417:2002 DB Graphical Symbols for Use on Equipment 

Reference Symbol Title Meaning 

5007 | On (Power) To indicate connection to the 

mains, at least for mains switches 

or their positions, and all those 

cases where safety is involved. 

5008  Off (Power) To indicate disconnection from the 

mains, at least for mains switches 

or their positions, and all those 

cases where safety is involved. 

5009 

 

Standby 

(Power) 

To identify the switch or switch 

position by means of which part of 

the equipment is switched on in 

order to bring it into the stand-by 

condition, and to identify the 

control to shift to or to indicate the 

state of low power consumption. 
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IEC 60417:2002 DB Graphical Symbols for Use on Equipment 

Reference Symbol Title Meaning 

5019 

 

Protective 

Earth Ground 

To identify any terminal which is 

intended for connection to an 

external conductor for protection 

against electric shock in case of a 

fault, or the terminal of a protective 

earth (ground) electrode. 

5021  Equipotentiality 

Connector 

To identify the terminals which, 

when connected together, bring 

the various parts of an equipment 

or of a system to the same 

potential, not necessarily being the 

earth (ground) potential, e.g. for 

local bonding. 

5036 

 

Dangerous 

Voltage 

To indicate hazards arising from 

dangerous voltages. 

 

 

5333 

 

Type BF 

Applied Part 

To identify a type BF applied part 

complying with IEC 60601-1. 

5334 

 

Electrostatic 

Sensitive 

Devices 

To indicate packages containing 

electrostatic sensitive devices, or 

to identify a device or a connector 

that has not been tested for 

immunity to electrostatic 

discharge.  

 

Prescription 

Only 

Caution: Federal (U.S.A.) law 

restricts this device to sale by or 

on the order of a physician. 
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System Requirements 
The specifications listed below are the minimum required by the software to run. Blackrock 
supplies an optional Host PC that is configured and tested by our engineers before it ships with 
your NeuroPort system. Please contact sales@blackrockmicro.com for more information. 

• Microsoft Windows 10 (x64) 
• AMD or Intel 2.0 GHz Dual Core CPU 
• 4 GB of RAM 
• 1x Gbps Ethernet interface card 
• 1 TB 3 Gbit/s SATA II HDD 

Cybersecurity Requirements 

• Host Computer Windows Firewall turned on 
• Latest version of Malware/Virus Software installed and enabled 
• Do not connect the computer hosting the Central software to the internet 
• Host computer enabled windows login with password 
• Host computer auto-logout enabled with a minimum of 5 minutes of inactivity set.  

mailto:sales@blackrockmicro.com
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System Description 
The NeuroPort System is available in two versions: standard or digital. Both systems have the 
same purpose, intended use, and indications for use, but differ in their subcomponents. The 
Digital NeuroPort System integrates the headstages/preamplifiers with the amplifier circuitry to 
digitize the neural signal closer to the electrodes. 

The diagrams below show an overview of the assembled system and subcomponents. Refer to 
the sections below for more detailed information on each component.  

Digital NeuroPort System 

NeuroPort System 
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Specifications 

Model Name NeuroPort Neural Signal Processor 

Power Requirements 110 VAC 60 Hz 6.0 A / 240 VAC 50 Hz 3.0 A  

Line Noise Serviceable Fuses 5 x 20mm, 250V, 1.6A, Slow Blow 

Compliance Standards IEC 60601-1, IEC 60601-1-2, IEC 60601-2-26, CSA listed 

Type of Protection Against 
Electric Shock 

Class I 

Degree of Protection Type BF Applied Part 

Mode of Operation Continuous 

Ingress Protection Ordinary Equipment, not fluid resistant, IPX0 

Operating Environment 10˚C to 35˚C, 5 to 85% R.H. (non-condensing) 

Storage Environment -20˚C to 50˚C, 5 to 95% R.H. (non-condensing) 
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Guidance and manufacturer’s declaration — electromagnetic immunity 

The NeuroPort System is intended for use in the electromagnetic environment specified below. The customer or the 
user of the NeuroPort system should assure that it is used in such an environment. 

Immunity test 
IEC 60601 test 

level 
Compliance 

level 
Electromagnetic environment — guidance 

  
 

 
 

 

 

 

Portable and mobile RF communications equipment 
should be used no closer to any part of the NeuroPort 
system, including cables, than the recommended 
separation distance calculated from the equation 
applicable to the frequency of the transmitter.  

Recommended separation distance 

Conducted RF  

IEC61000-4-6 

3 Vrms  

150 kHz to 80 MHz 

3 Vrms 

 
  150 kHz to 80 MHz 

 

  80 MHz to 800 MHz  

 

  800 MHz to 2.5 GHz  

Radiated RF  

IEC 61000-4-3 

3 V/m 

80 MHz to 2.5 GHz 

3 V/m  

   where P is the maximum output power rating of the 
transmitter in watts (W) according to the transmitter 
manufacturer and d is the recommended separation 
distance in meters (m). 

Field strengths from fixed RF transmitters, as deter-
mined by an electromagnetic site surveya should be 
less than the compliance level in each frequency 
rangeb. 

Interference may occur in the vicinity of equipment 
marked with the following symbol: 

 

 

NOTE 1 At 80 MHz and 800 MHz, the higher frequency range applies. 

NOTE 2 These guidelines may not apply in all situations. Electromagnetic propagation is affected by absorption and 
reflection from structures, objects and people. 

a   Field strengths from fixed transmitters, such as base stations for radio (cellular/cordless) telephones and land 
mobile radios, amateur radio, AM and FM radio broadcast and TV broadcast cannot be predicted theoretically with 
accuracy. To assess the electromagnetic environment due to fixed RF transmitters, an electromagnetic site survey 
should be considered. If the measured field strength in the location in which the NeuroPort system is used exceeds 
the applicable RF compliance level above, the NeuroPort system should be observed to verify normal operation. If 
abnormal performance is observed, additional measures may be necessary, such as reorienting or relocating the 
NeuroPort system. 

b   Over the frequency range 150 kHz to 80 MHz, field strengths should be less than 3V/m. 

 
Table 204–Guidance and manufacturer’s declaration – electromagnetic immunity – for all EQUIPMENT and 

SYSTEMS that are not LIFE-SUPPORTING (refer to 60601-1-2). 
  

Pd 2.1=

Pd 2.1=

Pd 3.2=
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Recommended separation distances between portable and mobile RF 
communications equipment and the NeuroPort system 

The NeuroPort system is intended for use in an electromagnetic environment in which radiated RF disturbances 
are controlled. The customer or the user of the NeuroPort system can help prevent electromagnetic interference 
by maintaining a minimum distance between portable and mobile RF communications equipment (transmitters) 
and the NeuroPort system as recommended below, according to the maximum output power of the 
communications equipment. 

Rated maximum 
output power of 

transmitter W 

Separation distance according to frequency of transmitter m 

150 kHz to 80 MHz  

P
V

d ]
5.3

[
1

=  

80 MHz to 800 MHz 

P
E

d ]
5.3

[
1

=  

800 MHz to 2.5 GHz 

 

0,01 0.12 0.12 0.23 

0,1 0.38 0.38 0.73 

1 1.2 1.2 2.3 

10 3.8 3.8 7.3 

100 12 12 23 

For transmitters rated at a maximum output power not listed above, the recommended separation distance d in 
meters (m) can be estimated using the equation applicable to the frequency of the transmitter, where P is the 
maximum output power rating of the transmitter in watts (W) according to the transmitter manufacturer. 

NOTE 1 At 80 MHz and 800 MHz, the separation distance for the higher frequency range applies. 

NOTE 2 These guidelines may not apply in all situations. Electromagnetic propagation is affected by absorption 
and reflection from structures, objects and people. 

 
Table 206–Recommended separation distances between portable and mobile RF communications equipment 

and the EQUIPMENT or SYSTEM - for EQUIPMENT or SYSTEMS that are not LIFE-SUPPORTING  
(refer to 60601-1-2).  

P
E

d ]
7

[
1

=
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Hardware 
Both available NeuroPort Systems include the Neural Signal Processor. The Digital NeuroPort 
System includes the Digital Hub, while the standard NeuroPort System includes the Front End 
Amplifier and its power supply.  

Neural Signal Processor (NSP) 

NSP showing the power switch (1), LCD display (2), analog inputs (3), digital inputs (4), 
serial I/O (5), analog outputs (6), audio outputs (7), digital outputs (8), and sync port (9). 

Note: The fiber optic link input connector has been relocated to the back panel in NSP 
versions 1.75 and above. The location of this port was previously under the sync port on 
the front panel 

The NSP is the real-time processor of the system. It performs all the digital processing of 
the signals, such as digital filtering, spike extraction, spike sorting. It also processes the 
data and transmits it to the Host PC through Ethernet UDP protocol. The NSP has 
multiple analog and digital input and outputs that can be programmed through the 
software or one of the supplied Software Development Kits (SDKs). Multiple NSPs may 
be synchronized for recording signals from a very large quantity of electrodes. 

1. Power Switch:  
It is used to turn the NSP ON and OFF. The LED above the switch will illuminate 
blue when the unit is on. 
Note: On NSP PN-7530, PN-9650, and PN-10411 this switch is a momentary 
switch to power down the NSP and does not turn main power to the device 
ON/OFF. See rear panel for mains switch for mentioned part numbers. 

2. LCD Display:  
It displays the current operating status of the unit. The statuses include, 
“Initializing”, “NSP Startup”, “NSP Running”, “NSP Standby”, and “Synchronized”. 

3. Analog Inputs:  
Auxiliary analog signals can be recorded through 16 analog input BNC ports. The 
analog source may range ± 5.0 V and should come from a source impedance of 
less than 100 Ω. The coupling of each input channel can be manually selected in 

 
Figure 1–NSP Front 
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the software. By default, channels 1-8 are AC-coupled and channels 9-16 are 
DC-coupled. 

4. Digital Input:  
Digital events can be recorded through the 16-bit DB37 input port. The pin 
diagram is shown below. DS is the digital strobe pin. D0-15 are data pins. EOP is 
reserved. SYNC is an output pin and can be used with external equipment to 
indicate when the port is scanned.  Input range is 0V-5V TTL levels.   The port is 
polled every 1/30000 of a second.  Strobed data is buffered up to 10 strobes per 
1/30000 of a second and is latched on the rising edge of the DS pin. 

 

5. Serial I/O:  
The port is an RS232 DB9 digital input/output port. The pin diagram is shown 
below. Currently, the software only supports this port as an input. Pin 2 is 
“Receive Data”, pin 3 is “Transmit Data”, and pin 5 is “Ground”.  The 
configuration of the port is: Baud rate: 115200, Data bits: 8, Parity: none, Stop 
bits: 1, Flow control: disabled. 

 
 

6. Analog Outputs:  
Four ± 5.0 V analog output BNC connectors can be used to send monitoring 
signals or stimulus waveforms to other connectors. 

7. Audio Output:  
The system sends a ± 1 V line-level audio signal of the selected data channel to 
two BNC ports (Left and Right channeled respectively) and one 3.5mm female 
stereo audio connector simultaneously. 

8. Digital Outputs:  
Four single-bit digital BNC outputs can be programmed for monitoring or timing 
functions. These ports can be setup to send a TTL signal if spike activity is 
detected on any particular neural channel. They can also be configured to output 
a digital pulse train at a user-defined frequency and duty cycle. Digital Output 1 
can also be used for syncing external equipment by sending a unique pulse 
every 14 seconds. The entire sync pattern will repeat every hour. See the Central 
Software Suite User Manual for more details. 

9. Sync Port:  
A synchronization pulse can be set as an optional line to inform external 
equipment when the NSP neural signal inputs and front panel ports are scanned. 
It is active on the rising edge of the signal. 

 
 

Figure 2–Digital In Pin Diagram 

 
 

Figure 3–Serial I/O Pin Diagram 
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NSP PN-4176 
 

 
NSP PN-7530  

 

  
NSP PN-9650 

 

 
NSP PN-10411 

 

 
 

Figure 4–NSP Back  
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10. Line Noise Cancellation Port:   
On PN-4176 hardware Line Noise Cancellation receptacle is combined with the 
main power receptacle. On PN-7530, PN-9650 and PN-10411 a separate power 
receptacle is used for hardware line noise cancellation.  To use this feature, plug 
a standard power cable into this port and enable the feature in software as 
described in the Central Software Suite User Manual.  
Note: This receptacle is optional and is not required to power and operate the 
NSP under normal conditions. 

11. Synchronization Port:  
This DB9 port is located on the back of the NSP and it is used to synchronize two 
NSPs. The synchronization occurs automatically as Central runs on both 
computers if the sync cable (Blackrock PN-5584) is properly connected between 
two NSPs. Some models may not have this port. To add synchronization 
capability to your NSP, please contact Blackrock Microsystems support at 
sales@blackrockmicro.com 

12. Fiber-optic Link:  
This port connects to the Amplifier using a fiber-optic cable. An LED to the right 
of the connector turns green when a link is established and turns yellow when the 
link is broken. 

13. Mains Power Entry: 
This supplies main power to the NSP and is required to power and operate the 
NSP. 

14. Mains Power Switch: 
Power switch used to turn main power ON/OFF to the NSP. Ensure this switch is 
in the ON position marked by the “I” on the switch. 

  

mailto:sales@blackrockmicro.com
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Digital Hub 

The Digital Hub receives digital signals from attached digital headstage accessory 
devices. Note that these accessory devices are not described in this instruction and are 
contained within their own instructions for use. 

The Digital Hub allows connection of multiple digital headstages. It is responsible for 
providing the sampling clock signal to the digital headstages as well as taking incoming 
digital information from the headstages and converting it into the optical domain to 
transfer to the Neural Signal Processor via a fiber-optic link, which is immune to 
electromagnetic field interference.  

Status LEDs 

There are six LEDs on the Digital Hub which can give the user information about the 
device status.  

If the Digital Hub is powered (plugged in) the “Power” LED will be blue. The Digital Hub 
is powered by a medical grade power supply that is included as part of the Digital Hub 
packaging.   

If the fiber-optic connection between the NSP and the Digital Hub is present, the “Fiber 
Optic Data Link” LED will be green (otherwise yellow).  

Finally, LEDs 1-4 show the source status of the incoming data streams. If the LED is 
green for an input, then the Digital Hub is receiving data from a connected digital 
headstage correctly. If the LED is yellow then data is not being transmitted to the Digital 
Hub correctly. If the input LED is not lit then there is either no data being received or the 
Digital Data Cable is not plugged into the input slot. 

 

 



 
 
 
 

Revision 6.00 / LB-0323 – NeuroPort Biopotential Signal Processing System IFU  
© 2021 Blackrock Microsystems, LLC 

23 

Digital Inputs 

The Digital Hub is designed so that input one has the highest priority, then input two, and 
so forth. This means that if two 96 channel Digital Headstages are connected, in inputs 
two and three respectively, input two will send the entire 96 channels to the Neural 
Signal Processor (NSP) but input three will send only the first 32 channels to the NSP. 
The Digital Hub will always send the first 128 channels to the NSP in this way, unless 
there are less than 128 channels in which case it will send all channels.  

Patient Ground 

This rear panel of the device has a green connection labeled GND. This is the patient 
ground connector if needed for a reference ground. 

Fiber Optic Link 

The fiber optic link connector is located on the back panel of the Digital Hub and 
provides a connection to the Blackrock Neural Signal Processor via a fiber optic cable. 

Fast Settle 

The fast settle input connector is located on the back panel of the Digital Hub.  This 
connector is tied to each of the four Digital Data Cable inputs.  The signal fed into the 
BNC connector is passed through the system to the connected digital headstages, 
providing a fast settle signal to the attached digital headstage(s). When the fast settle 
input receives a TTL high it will blank the signal. 
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Neural Signal Amplifier 

The Amplifier receives analog signals directly from the electrodes or via headstages 
(e.g. unity-gain voltage followers) depending on the impedance of the electrodes. The 
analog signals are amplified, filtered (1st-order high-pass at 0.3 Hz and 3rd-order low-
pass at 7,500 Hz), and digitized (30 kHz, 16-bits at 250 nV resolution), converted into 
the optical domain and then transmitted to the NSP via a fiber-optic link, which is 
immune to electromagnetic field interference. At a later stage, digital filtering will allow 
these two signals to be separated and recorded in different data files. 

 
 

The Amplifier case is not connected to the earth ground. The Amplifier ground is isolated 
and floating. There are ESD shunt circuits that will conduct differences of 1000 V or 
more. 

The Amplifier has four 34-pin banks. Each bank consists of 32 channels, a bank 
reference pin, and a ground pin. The electrodes within each bank are differentially 
amplified with respect to the reference input of the same bank. If channels on all banks 
are to be electrically measured with respect to a common reference, this reference 
needs to be connected to the reference input on every bank. 

 
 

 
Figure 5–Neural Signal Amplifier 
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Additionally, four 6-pin APS banks provide power (± 5V) to the headstage and can 
deliver 130 mA of combined current from the Amplifier. The ground pins on every bank 
are tied together. For best results, the Amplifier should be the central grounding point for 
electrical ground connections to the patient. 

Amplifier Power Supply (APS) 

The APS consists of five analog and digital supply channels with monitoring, 
sequencing, and emergency shutdown controls. 

 

The On/Off switch is located on the back of the unit. Once it is switched on, the APS will 
start a power-up sequence of analog and digital supplies ending with the green ON LED 
illuminating. When the power switch is turned off this sequence is reversed, and the 
output of the APS is tied to ground. In the event of an error in voltage or power delivery, 
the APS will shut down and a red error LED will turn on. After checking all Amplifier and 
patient cable connections for any inadvertent shorting, turn off the APS and turn it back 
on to reset the error. 

  

 
 

Figure 6–Amplifier Input Schematic 

 
Figure 7–Amplifier Power Supply 
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Cables 

In addition to the above hardware components, the system also comes with a few 
cables. Note that standard power cables for the NSP, Front End Amp Power Supply, 
and/or Digital Hub are included, but not shown below. The fiber-optic cable is used to 
connect the Front End Amplifier or Digital Hub to the Neural Signal Processor, the 
Ethernet cable is used to connect the Neural Signal Processor to the recording 
computer, and the Front End Amplifier Power Supply cable is used to connect the Front 
End Amplifier to its power supply.  

 
 

 
 

Figure 8–Fiber-optic Cable 

 

 
 

Figure 9–Crossover Cable 

 

 
 

Figure 10–Amplifier Power Supply (APS) Cable 
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Accessories 
Blackrock sells accessories for use with the system. Primarily, these include headstages for 
interfacing the patient contacting electrodes to the system. The Digital Hub may have Digital 
Headstages attached to it and the Front End Amplifier may have analog headstages attached to 
it.  

Digital Headstages 

Digital Headstages are required to allow the Digital NeuroPort System to interface with 
electrodes. Which digital headstage to select depends on the connector type of the 
electrodes. These connector types and the selection process is not explained here, but 
is explained in the contents of the instructions for use for each digital headstage. The 
currently available digital headstages include: 

• NeuroPlex E128 (PN 10906, 10907) 
• NeuroPlex E96 (PN 10908, 10909) 

Analog Headstages 

The high input impedance and low bias current of the Amplifier inputs make it possible to 
connect microelectrodes with 20 kΩ (at 1kHz) or lower impedance values directly to the 
Amplifier inputs without the need for a headstage. This configuration has the advantage 
of avoiding noise added to the signals by the headstage, but it makes the application 
more susceptible to environmental electromagnetic noise. To minimize environmental 
noise, it is recommended to keep direct electrode connections shorter than 20 cm (8 
inches). For longer connections, headstages from Blackrock Microsystems are 
recommended. Headstages allow microelectrodes with impedances up to 5-MΩ (at 
1kHz). 

Which analog headstage to select is dependent on the connector type on the electrodes. 
These connector types and the selection process is not explained here, but is explained 
in the contents of the instructions for use for each headstage. The currently available 
analog headstages include: 

• 64 Channel Splitter Box (1-64) (PN 6832) 
• 64 Channel Splitter Box (65-128) (PN 7121) 
• 16 Ch Macro Cabrio Butterfly Adapter (PN 7698) 
• 32 Ch Cabrio Butterfly Adapter (PN 6852) 
• Cabrio Butterfly Adapter (PN 6480) 
• Quad IDC-10 Adapter (PN 7341) 
• Patient Cable with Impedance Tester (PN 4460) 
• Patient Cable with Filament Film (PN 6735, 6736) 
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Digital Neural Signal Simulator (DNSS) 

The Digital Neural Signal Simulator (DNSS) supplies simulated field potentials and 
action potentials (spikes) as well as sine waves at different frequencies. It can be used 
to test a recording system in lieu of being connected to a subject. 

. 

 
  

 
 

Figure 11–Digital Neural Signal Simulator 
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Software 
Central can be run from the desktop shortcut, the Start menu shortcut, or by navigating to the 
executable in the Blackrock Microsystems directory in Program Files. The Central main 
application connects to a Blackrock Neural Signal Processor to configure hardware channels 
and acquire data. Incoming data can be processed and visualized in various ways before being 
saved for future analysis.  

Central Main Window 

The Central Main window provides access to all functions, 
features, and settings within the Central Software Suite.  

Hardware Configuration contains individual channel 
configurations as well as system settings. The main panel 
displays channels in icon or list view as selected in the tool 
bar. Double clicking selected channels will open the channel 
properties window for editing. Channels are filtered by 
clicking the categories listed on the left pane of the window. 
Additional settings are found under the Settings heading at 
the bottom of the left pane.  

Spike Panel displays detected spikes on the front-end 
amplifier channels in a grid-graph form and is often the 
fastest way to visualize overall system function. If spike-
sorting rules are defined, the spikes belonging to different 
units will be displayed in different colors. Double click any 
channel to display the Single Neural Channel Window. 

Raster Plot displays the occurrence of spike events on 
many channels over time. All channel types may be shown 
in this window. Continuous traces and comments can also 
be shown on the plot.  

Single Neural Channel displays the selected channel in a 
continuous data trace, strip chart, and waves panel. Use 
this window to define spike sorting rules and to view single 
channel activity.  

Activity Map color codes the firing rate of neurons recorded by each electrode on a two-
dimensional grid. An electrode map file dictates the spatial arrangement of channels. 
Use this window to quickly visualize spike rates over all channels.  

File Storage contains the controls to start and stop recording. Additional settings, such 
as file type, name and path may be edited here.  

Signal to Noise Ratio displays the ratio of signal to noise for each channel. Use this 
window to view and record valuable information about signal quality and electrode 
functionality.  

Neural Modulation displays a histogram of changes in firing frequency over time. Use 
this window to see which channels are recording from neurons with variable firing rates.  

 
Figure 12–Central Main Application 
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Thresholding allows the user to set a global spike detection threshold as a value or a 
multiplier of the root mean squared signal energy.  

Impedance Tester measures and displays the impedance of each electrode. Use this 
window to assess electrode functionality.  

Crosstalk measures and displays the amount of signal shared between channels. Use 
this window to mark and disable redundant channels.  

N-Trode allows configuration and visualization of N-Trode groups. The Spike Display at 
the top of the window shows spikes on each channel.  The Peak/Valley panel is used to 
define spike units for the group. The Continuous Data Display shows the full signal from 
the group.  

Oscilloscope visualizes the signal acquired by any channel. Use this window to view, 
measure and compare signals with custom triggers. 

Digital Filter Editor is a MATLAB utility that creates custom digital filters which can be 
applied to acquired signals.  

Add Comment creates a time-stamped text comment which is included in the neural 
events (.nev) file.  

nPlay loads and replays saved data files for analysis and re-recording.  

System Load displays the volume of incoming data from the Neural Signal Processor. 

Menu Bar 

The menu bar is found at the top of the Central Main 
window and contains File, Tools, and Windows drop-
downs. 

File 

The File menu contains functions to load and 
save various configuration files as well as the 
option to close applications and shut down the 
Neural Signal Processing hardware. 

Load System Settings: Load channel settings 
in the ‘.ccf’ and ‘.rcf’ formats. 

Load Sorting Rules: Load system-calculated 
Histogram Peak Count sorting rules in the ‘.csr’ 
format. 

Load PCA Basis: Load system-calculated 
principle component analysis basis vectors in 
the ‘.cfsd’ format. 

Load Digital Filters: Load digital filters in the 
‘.xml’ format created by the Digital Filter Editor. 

Save System Settings: Saves the channel 
settings currently set in Hardware 
Configuration. 

 
Figure 13–Central File Menu 
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Save Sorting Rules: Saves spike-sorting parameters. 

Save PCA Basis: Saves PCA basis vectors calculated during spike sorting. 

Close Applications: Closes Central Suite programs while leaving the hardware 
running. 

Hardware Standby and Close: Closes Central Suite programs and puts 
hardware into standby mode. The system must be in standby mode for firmware 
updates. 

Hardware Shutdown and Close: Closes Central, all its associated applications 
and shuts down the Neural Signal Processor. Manually turn off the system power 
switch to complete hardware shutdown. 

Tools 

The Tools menu contains functions regarding thresholding, spike-sorting and 
general application settings. The spike sorting options are discussed on Page 39. 

Options 

Sets various general options for the Central Software Suite. 

Allow Multiple Instances Of  

Allows more than one instance of each checked window type to be 
opened.  

Sorting Log Rules 

Sorting rules are the manually or automatically defined spike unit 
classifications used to recognize and separate neural spike events.  

Do Not Log Sort Changes: Disables sort change logging. 

 
Figure 14–Central Options 
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Log Sorting Changes on ‘Record’: Will automatically log the spike-
sorting model, the signal to noise ratio summary, and the crosstalk 
summary if rebuilt during recording. 

Log Sorting Changes ‘Always’: Will log the spike-sorting model, the 
signal to noise ratio summary, and the crosstalk summary any time it is 
rebuilt. 

Log PCA coordinates on ‘Record’: Will log the spike-sorting model only 
when recording begins. 

File Storage App Interface 

Choose to save files in the 2.x interface or the TOC interface. The TOC 
interface is designed to be used in a clinical setting where patient 
information is entered. The 2.x interface is preferable in a research setting 
where files are manually named. For more information of file types see 
Page 48. 

Single Neural Channel App Interface 

Allows changes to the channel configuration in Single Neural Channel 
viewer or in the Edit > Properties menu. 

Auto Impedance Interface 

Configures impedance testing for the Patient Cable or CerePlex 
headstages. 

Autoload System Settings 

Upon opening Central, the ‘.ccf’ file input below will be loaded. If the field 
is left blank, Central will prompt the user to select a ‘.ccf’ file. 

Windows  

The Windows menu contains system and software summary information as well 
as shortcuts to Central applications 

About: Displays the version of the software and the firmware of the system. 
These version numbers may be needed if you contact Blackrock support. 

System Summary: Displays average number of units per channel if using 
automatic histogram peak-count sorting. Options to disable cross talking 
channels and launch the impedance tester are also found here. 
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Hardware Configuration 

The Hardware Configuration panel contains individual channel configurations as well as 
system settings. The main panel displays channels in icon or list view as selected in the 
tool bar. Double clicking selected channels will open the channel properties window for 
editing. Channels are filtered by clicking the categories listed on the left pane of the 
window. Additional settings are found under the Settings heading at the bottom of the left 
pane.  

Channel Sorting 

Central Suite supports front end amplifier inputs, as well as analog, digital and 
serial inputs and outputs. Channels can be viewed in icon, list, or full row detail 
modes selectable in the tool bar on the toolbar. Each channel can be sorted 
based on function under Signal Types, or based on physical location under NSP 
Channels. 

Configuring Channel Properties 

Select one, or multiple channels in the right pane of the Hardware configuration 
window. Once all channels of interest are selected, right-click then select 
properties, or click the Channel Properties icon in the toolbar. Each channel type, 
and their respective options are described below. 

 
Figure 15–Hardware Configuration 
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Front End Analog Inputs 

All parameters for front end input channels are listed below.  

Label: A user-defined name for the 
specific channel. Multiple channels 
labels can be automatically assigned 

Digital Range: Fixed entry showing the 
range of digital values that analog 
signals are mapped to.  

Analog Range: Fixed entry showing the 
range of analog values measured. 

Analog Units: Unit of analog signal 
measurement displayed for reference. 

External Gain: Gain value of the 
headstage. All Blackrock systems use a 
gain of 1. 

Enable Line Noise Cancellation: Enables cancellation of 50 or 60 Hz noise. 

Estimate Time Constant: The period over which line noise parameters are 
determined. 

LNC Method: Selects software or hardware line noise cancellation. 

Filter: Select a digital filter to apply to continuous data.  

Graphical Chooser: Visualize the continuous signal filter in place.  

Sampling Rate: Select the sampling rate of data acquisition. 

Channel Chooser: Select the sampling rate for data acquisition on any channel. 

Raw Data: Record raw data stream before filtering or sorting is applied. 

 
Figure 16–Analog Input Properties 

 

 
Figure 17–Edit Multiple Labels 
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AC Input Coupling: High pass filter to remove DC offset. 

Software Reference Selection: Apply software referencing to local field 
potential or both Local field potential and spike data. 

Reference Electrode:  Select channel to use as software reference. 

Enable Spike Processing: Allow detection of spike events on channel. 

Filter: Filter selection for spike event processing. 

Graphical Chooser: Allows visualization of the spike processing filter in place. 

Threshold Value: Voltage threshold for classification of a spike event in mV. 

RMS Threshold: Set parameters for auto-threshold calculation. 

Sorting Algorithm: Set the sorting algorithm for a channel as described in Spike 
Sorting on Page 39. 

Enable Amplitude Rejection: Rejects waveforms exceeding a specified 
amplitude. 

Upper/Lower Limit (uV): Voltage limits for amplitude rejection. 

 
Figure 18–Filter Properties 



 
 
 
 

Revision 6.00 / LB-0323 – NeuroPort Biopotential Signal Processing System IFU  
© 2021 Blackrock Microsystems, LLC 

36 

Analog Output 

Analog output properties are accessed from the left side bar of the Hardware 
Configuration window and allows the user to set the properties of the analog 
output ports.  Analog outputs can function as monitor channels, directly mirroring 
signals of interest, or as waveform generators. Each modality has output and 
triggering parameters defined below. 

Label: User-defined channel label. 

Function: Assigns the analog channel function.  

Analog Output: Continuous Monitor 

An analog output channel configured as a continuous monitor will scale a user 
input signal into a plus or minus 5 V output signal.  

Input Range: Input voltage range displayed for reference. 

Output Range: Output voltage range displayed for reference. 

Track Most Recently Selected: When enabled, the channel selected in Spike 
Panel, Single Neural Channel, or Raster Plot view is used as the monitor input. 

Channel: An analog output channel configured as a spike monitor will scale a 
user selected input signal into a plus or minus 5 V output signal. 

Analog Output: Spike Monitor 

An analog output channel configured as a spike monitor will scale a user 
selected input signal into a plus or minus 5 V output signal containing only 
identified spike events. 

Input Range: Input voltage range displayed for reference. 

Output Range: Output voltage range displayed for reference. 

 
Figure 19–Analog Output: Continuous Monitor 
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Track Most Recently Selected: When enabled, the channel selected in Spike 
Panel, Single Neural Channel, or Raster Plot view is used as the monitor input. 

Channel: An analog output channel configured as a spike monitor will scale a 
user input signal into a plus or minus 5 V output signal containing only identified 
spike events.  

Analog Output: Sine Waveform 

An analog output channel configured as a sine waveform generator will produce 
a user defined sine wave on a user defined trigger stimulus.  

Amplitude (mV): Amplitude of the output sine wave. 

Frequency (Hz): Frequency of the output sine wave. 

Offset (mV): DC offset of the output sine wave. 

Wave Number: Select which of five waveforms are configured and used. 

Trigger: Triggering options are explained on Page 34. 

Analog Output: Custom Waveform 

An analog output channel configured as a custom waveform generator will 
produce a user defined waveform on a user defined trigger stimulus. 

Wave Number: Select which of five waveforms is configured and used. 

Number of Phases: Number of voltage phases in the waveform. 248 are 
available. 

Offset (mV): DC offset of the waveform. 

Phase: Selects which phase is being configured. 

Amplitude (mV): Phase amplitude. 

Duration (ms): Phase duration. 

Repeats: Indicates the number of times to repeat the waveform once triggered.  
A value of 0 will repeat the waveform indefinitely.  

 
Figure 20–Analog Output: Sine Generator 
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Analog Output: Triggering 

Sine and custom waveforms can be triggered by different conditions listed below. 

Instant: Waveform triggers when OK or Apply are clicked. 

Digital Input Rising Edge: Waveform triggers when a user defined digital input 
pin transitions from low to high.  A digital input bit must be selected. 

Digital Input Falling Edge: Waveform triggers when a user defined digital input 
pin transitions from high to low.  A digital input bit must be selected. 

Spike Unit: Waveform triggers when a sorted unit is detected on a defined 
channel.  

NeuroMotive ROI: Triggers when a subject enters or exits a selected region of 
interest. 

Extension: Waveform triggers based on custom extension code loaded onto 
hardware. 

Digital Input 

Digital input properties are accessed from the left side bar of the Hardware 
Configuration Window and allows the user to set the properties of the digital input 
ports. Digital inputs can synchronize external hardware and pass digital data into 
neural recordings. Digital Inputs may take on the functions listed below.  

16-bit on word strobe: Reads 16 bits on the rising edge of the strobe pin. 

 
Figure 21–Analog Output: Custom 
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16-bit on bit changes: 16-bit read when any bit changes from LOW to HIGH or 
from HIGH to LOW. 

16-bit on rising edge: 16-bit read when any bit changes from LOW to HIGH. 
Each bit indicates if a LOW to HIGH change occurred on each digital pin. 

16-bit on falling edge: 16-bit read when any bit changes from HIGH to LOW. 
Each bit indicates if a HIGH to LOW change occurred on each digital pin. 

8-bit strobe / 8-bit bit changes: Reads bits 0-7 on the rising edge of the strobe 
pin and reads bits 8-15 if bits 8-15 changed from LOW to HIGH or HIGH to LOW. 

8-bit strobe / 8-bit bit rising edge: Reads bits 0-7 on the rising edge of the 
strobe pin, and bits 8-15 indicate if digital pins D8-D15 changed from LOW to 
HIGH. 

8-bit strobe / 8-bit bit falling edge: Reads bits 0-7 on the rising edge of the 
strobe pin, and bits 8-15 indicate if digital pins D8-D15 changed from HIGH to 
LOW. 

Digital Output 

The Digital Output Window is accessed from the left side bar of the Hardware 
Configuration Window and allows the user to set the properties of the digital 
outputs. Digital outputs can function as spike detection monitors, timed function 
generators, or triggered events.  

Digital Output: Monitor Electrode 

A digital output in monitor electrode mode will send a high pulse when a sorted 
spike unit is detected on a defined channel. 

Track Most Recently Selected: When enabled, the channel selected in Spike 
Panel, Single Neural Channel, or Raster Plot view is used as the monitor input. 

Source: Select which channel to monitor. 

Monitored Units: Select which spike unit classifications to trigger on. 

 
Figure 22–Digital Output Properties 
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Digital Output: Timed 

A digital output in timed mode will send a pulse train with specified parameters. 
The signal can be configured by setting frequency and duty cycle, or samples 
high and low.  

Frequency (Hz): The number of pulses per second. 

Duty Cycle: The percentage of time a pulse train is high. 

Samples High: Number of 30kHz sample periods output should be held high.  

Samples Low: Number of 30kHz sample periods output should be held low.  

Offset (mV): DC offset voltage of the digital output. 

Digital Output: Triggered 

A digital output in triggered mode will send a pulse when the selected trigger 
stimulus occurs.  

Digital Input Rising Edge: Waveform triggers when a user defined digital input 
pin transitions from low to high.  A digital input bit must be selected. 

Digital Input Falling Edge: Waveform triggers when a user defined digital input 
pin transitions from high to low.  A digital input bit must be selected. 

Spike Unit: Waveform triggers when a sorted unit is detected on a defined 
channel.  

NeuroMotive ROI: Waveform triggers when a subject enters or exits a region of 
interest. 

Extension: Waveform triggers based on custom extension code loaded onto 
hardware. 

Serial I/O 

The Serial I/O Properties window 
displays the serial communication 
parameters and allows the user to name 
and enable the serial port.  Serial 
communication parameters cannot be 
changed. 

 
 
 
 
 
      

 
Figure 23–Serial I/O 
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Global Settings 

Spike Width (samples): The number of samples recorded around a detected 
spike event.  

Pre-threshold Samples: The number of samples to record preceding a 
threshold crossing.  

Line Noise Frequency (Hz): The line frequency of the system, either 50 Hz or 
60 Hz.  

LNC Reference Channel: The reference channel used to compute system line 
noise. The extracted line noise template for each channel can be viewed in 
Single Neural Channel when the Raw/LNC button is checked. 

  
 
 
 
 
 
 
 
 
 

 
Figure 24–Hardware Configuration Settings 
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Filters 

This window displays the details of a selected digital filter in a bode plot and key 
numerical parameters.  

Auto Thresholding 

This window allows the user to specify the auto thresholding properties for spike 
detection.  

Threshold Multiplier: To register as a spike event, signal energy between 1 and 
5 kHz must exceed the energy of the noise by a factor of the threshold multiplier 
level. 

Channel: Applies noise boundary properties to this channel. 

Dimensions of the Ellipsoid: Radius of the noise ellipsoid in the along each 
axis. 

Center of Ellipsoid: Center of the noise ellipsoid in cartesian coordinates. 

Rotation of Ellipsoid: Rotation angle of the noise ellipsoid around each axis. 

 
Figure 25–Filter Properties Display 
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Spike Sorting 

The Spike Sorting Properties Window allows the user to specify the rules and 
settings for the spike sorting algorithms. The default settings are recommended 
but altered settings may produce better results in unique use cases. Four spike 
sorting methods are available: Manual PCA, k-means PCA, DBSCAN PCA, and 
Histogram Peak Count. Each method is described below. 

Manual PCA 

Manual PCA uses principle component analysis to generate a feature 
point for each spike event.  The user manually defines unit classifications 
by drawing an ellipsoid around each cluster of feature points within the 
feature space. 

Wave Basis Size: The number of waveforms to use to calculate the PCA 
basis vectors.  

Update Basis Multiplier: The PCA basis vectors will be recalculated 
after the number of samples exceeds the basis size times the basis 
multiplier. Zero means don’t recalculate. 

k-means PCA 

k-means PCA algorithms automatically generate ellipsoids around k 
number of clusters to sort recorded units.  

Wave Basis Size: The number of waveforms to use to calculate the PCA 
basis vectors.  

Update Basis Multiplier: The PCA basis vectors will be recalculated 
after the number of samples exceeds the basis size times the basis 
multiplier. Zero means don’t recalculate. 

Outlier Removal: Removes outliers exceeding this number of standard 
deviations from the centroid of each group. 

Minimum Group Size: Remove any groups that have fewer than this 
number of spikes. 

Merge Centroids: Merge two groups if the merged group has a standard 
deviation less than this multiplier times the product of the standard 
deviations of both groups. 

Number k-means groups: Number of k-means groups to use for sorting. 

DBSCAN PCA 

Density Based Spatial Clustering of Applications with Noise is a principle 
component analysis method that automatically chooses the quantity, 
radius, and position of each cluster based on point density. 

Wave Basis Size: The number of waveforms to use to calculate the PCA 
basis vectors.  

Update Basis Multiplier: The PCA basis vectors will be recalculated 
after the number of samples exceeds the basis size times the basis 
multiplier. Zero means don’t recalculate. 
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Histogram Peak Count 

Collected waveforms are broken down into high frequency and low 
frequency components. Each spike event is plotted on an axis composed 
of these two components. A histogram is constructed and clusters are 
estimated by determining peaks and valleys. 

Valley Percentage: A valley is identified at a height less than the first 
peak height times the valley percentage value. 

Close Peak Percentage: The second peak is identified at the height of 
the valley plus the height of the three-point mean centered at the valley 
multiplied by the close peak percentage. 

Freeze Time (minutes): Time spent analyzing the number of units on 
each channel. 

Update Rate (# spikes): The number of spikes that must be collected 
within each unit before the histogram is updated. 

Minimum Peak Percentage: Minimum peak height is calculated by 
adding the valley height to the total number of samples used times the 
minimum peak percentage. 

Artifact Rejection 

Maximum Simultaneous Channels: If more than the maximum number 
of channels contain simultaneous spike events, the events are all 
rejected. 

Refractory Period: The number of samples for which spike detection is 
barred after a spike event. 

 
Figure 26–Spike Sorting Properties 
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Tools Menu 

The main Central Window Tools menu 
contains several Spike Sorting options. 

Thresholding: Set the manual threshold 
level for all channels as an RMS multiplier or 
a fixed voltage value. 

Options: See below. 

Lock Unit Statistics: Disables continuous 
updates of spike sorting rules. 

Rebuild Spike-sorting Model: Restarts the 
automatic spike-sorting function. 

Continuous Spike Sorting: Selecting this 
item will continuously adjust the spike-sorting 
statistics including the splitting and merging 
of units. This is not recommended for use 
while recording.  

Build PCA: Builds the PCA basis vectors for 
all channels with PCA based spike sorting. 

Assisted Spike Sorting: Enable k-means, 
DBSCAN, or all PCA methods for spike 
sorting.  

Adaptive Filtering 

Recorded signals may contain unwanted information from sources of external 
noise, such as magnetic eye-tracking systems, monitors, and subject reward 
systems. The Adaptive Filtering feature can use a noise signal as a reference for 
neural signal channels.  

Adaptive Filtering: Choose one or two channels to reference. 

Reference Channels: Select channels to be used as references. 

 
Figure 27–Tools Menu 

 

 
Figure 28–Adaptive Filtering 
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N-Trode Groups 

N-Trode channel groupings are user defined electrode subsets created to record 
signals from proximal regions. When any single unit spike is detected within the 
N-Trode, the signals from all component electrodes are saved and registered as 
events. The Central Suite supports multiple N-Trode sets containing up to four 
electrodes each. Multiple single channels are linked and spike sorting occurs on 
the N-Trode as a single entity. To define N-Trode groups, open a group and add 
channels to it with the arrow buttons or by double clicking.  

  

 
Figure 29–N-Trode Properties 
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Spike Panel 

Spike panel displays detected spikes on the front-end amplifier channels in a grid-graph 
form and is often the fastest way to visualize overall system function. Double click any 
channel to display the Single Neural Channel window. The layout and graphical settings 
of the grid and individual channels can be changed in the right-click menu or the toolbar. 
A map file can be applied to the display to change the spatial arrangement of the 
channels on the screen to match the electrode array in use. If spike-sorting rules are 
defined, the spikes belonging to different units will be displayed in different colors. 

  

 
Figure 30–Spike Panel 
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Spike Panel Settings 

 Load Map File: The default map file for the spike panel is a 16x8 grid. 
Custom map files matching the spatial arrangement of your electrode ship with 
each Blackrock Electrode Array. Contact Blackrock Support at 
support@blackrockmicro.com for an additional copy of this file. 

Load Default Map File: The default channel map will be loaded. 

 Map File Information: Display information about the current map file. 

 Time to Screen Refresh: Set the length of time spike waveforms will 
trace without refreshing. 

 Open Selected Channels: Individual or groups of channels can be viewed by 
selecting Open Selected Channels in the right-click menu or the top menu bar. 

Show Labels: Display channel information on the cursor.  

 Refresh Screen: Manually refresh the spike panel display. 

 Magnify Current Channel: Toggle mouse-hover magnification 

 Spike Scale: Adjust the visual amplitude of displayed spikes. 

 Broadcast Channel Selections: Duplicate channel selection on other 
instances of Central running on computers connected to an Ethernet switch. 

 Level of Criticality: Display the current application load. 

Raster Plot 

The Raster Plot displays the occurrence of spike events on many channels over time. All 
input channel types may be added, removed, moved, and scaled in this window. 
Continuous traces and comments can also be shown on the plot. 

  

 
Figure 31–Raster Plot 
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Tool Bar 

 Play: Configure the display to fill and then refill repeatedly.  

 Scroll: Configure the display to scroll right to left. 

 Pause: Pause the display. 

 Increase/Decrease Font Size: Change the font size of channel labels. 

 One Line per Channel: Display all units from each channel on one line.  

 Split Channels: Display each unit on a separate line. 

 Seconds per Division: Change the time scale markers on the plot. 

 Decrease/Increase Size: Change the size of selected channels. 

 Minimize/Maximize Size: Minimize or maximize the size of selected 
channels. 

 Delete: Remove selected channel from the plot. 

 Move Up/Down: Move selected channels through the channel list.  

 Continuous Data Scale: Set the amplitude of continuous signals. 

 Show Neural Events: Display neural events as impulses on the raster plot. 

 Show Continuous Data: Display continuous channel trace. 

 Raw Toggle: Toggle between filtered continuous and raw data. 

 Update: Refresh the display. 

 Sort: Sort channels in the raster plot display by Channel ID, Recording Mode, 
or Unit ID. 

 Choose Channels: Select channels to display. 

 Add All: Display all channels. 

 Clear All: Remove all channels from display. 

 Open Selected Channels: Open selected channels in Single Neural Channel. 

 Broadcast Channel Selections: Duplicate channel selection on other 
instances of Central running on computers connected to the Ethernet switch. 

 Level of Criticality: Display the current application load.   
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Single Neural Channel 

Single Neural Channel visualizes the selected channel in a continuous data trace, strip 
chart, and waves panel. Spike sorting is configured in this window.  

Channel Configuration 

 Channel ID: Select a channel from the drop-down menu. 

 Channel Selector: Scroll through channels.  

 Channel Properties: Open the Channel Properties window. 

 Persist Spikes: When selected, the last detected spikes will remain in the 
wave viewer for sorting. 

 View Tool Tip: Display time and amplitude values at the cursor position. 

 View Continuous: Toggle the Continuous Data Display. 

 View Classification: Toggle the Online Classification Display. 

 Broadcast Channel Selections: Duplicates channel selection on other 
instances of Central running on computers connected to the Ethernet switch. 

 

 
Figure 32–Single Neural Channel 
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Spike Display 

The spike display panel shows neural events. It contains the wave panel where 
spikes can be visualized and sorting hoops can be defined, as well as the strip 
chart. Use the vertical slide button at the right of the panel to set the voltage 
range. The default time scale of the spike display window is 1.6 milliseconds. The 
samples width of each spike can be defined in the Global Settings section in the 
Hardware Configuration module within a range of 1.0 to 4.3 milliseconds. 

Clear: Clear the spike display. Automatic clearing will occur as well, maintaining 
the number of spikes shown in the drop-down menu. 

Show Spikes: Select which spike units to display. 

Hoops Spike Sorting: To define a spike unit, click Define next to a unit window 
box on the right side of the window. A color box will appear in the lower right of 
the spike window. Drag the selector to include all contacted waveforms in the 
unit. Only waveforms within a selection will be classified. The Define All button 
will initialize all five units. 

Unit Mapping: Select unit definitions to remap, combine, or map to noise. 

3D PCA On-line Spike Classification: If manual PCA is selected, spike sorting 
is performed using online PCA analysis within the PCA space. PCA spike sorting 
can classify up to five different signals per channel, each selected signal receives 
a separate color. An ISI Histogram is also displayed for each classified spike.  

A user can sort an individual channel by clicking on the Feature tab. Click the 
Define button next to the classified spike to sort that unit. Hold the Ctrl key and 
draw around the cluster. An ellipsoid will be created which is used to define a 
unit. You may also change the size of the ellipsoid by pressing R then moving the 
handle. 

k-means & DBSCAN PCA:  Generates ellipsoids when the k-means or DBSCAN 
PCA is selected in the Feature tab. 

Manual Override Options 

Automatic spike sorting can be overridden on an individual channel by clicking on 
the Pattern view. Click the Edit button next to the classified spike to resort to a 
manual sorting option. Press <C> to see all available controls. Hold down the 
<Ctrl> key and draw an ellipse in the Pattern view around the cluster that you 
would like to define as a spike. You may also change the diameter of the ellipse. 
Once the ellipse is placed around a cluster of points. The word “Overridden” will 
appear next to the sorted unit.  
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File Storage 

Central Software Suite supports file storage via the TOC and 2.x interfaces. 2.x is the 
most common basic file interface for research. The TOC interface names files with a 
timestamp and patient name, as well as file splitting long recordings. Data files are 
saved in .nsx format. .nsx data is stored in bits with 250 nV/bit resolution. Timestamps 
appended to filenames by Central use Greenwich Mean Time (GMT) referencing your 
local computer’s clock and time zone information. 

TOC Interface 

The TOC interface allows the user to enter patient information and select a path 
for the files that are created when the session is initiated. The Central Software 
Suite assigns a numeric name to the files which indicates the date and time of 
the recording. For example, 20110124-152145 indicates that the data file was 
recorded on January 24, 2011 at 3:21:45 PM GMT. System settings will be saved 
in the same folder as the data file. 

File Splitting: Splitting large files into smaller sizes may aid offline analysis. File 
size limit is defined in the View > Options menu. To disable file splitting, check 
the disable file-splitting box in the file storage module. 

File Description: Up to 256-character comments can be entered here to be 
saved with the file. Comments need to be entered prior to recording a data file. 

Record For: Specify an amount of time that the Central Software Suite will 
record data. Once the time has expired, the recording will stop automatically. 

Remote Recording Control: Allows digital in signals to Start, Stop, Pause, and 
Resume file recording through the digital input port, or the serial I/O port. Click 
the Setup button below the remote recording check box to set user-defined hex 
values for each remote recording function. For an example of remote recording 
control see Page 64. 

 
Figure 33–TOC Interface 

 



 
 
 
 

Revision 6.00 / LB-0323 – NeuroPort Biopotential Signal Processing System IFU  
© 2021 Blackrock Microsystems, LLC 

53 

Record: Begin recording data. 

Pause: Pause recording. 

Stop: Stop recording and save file. 

2.x Interface 

The 2.x interface allows the user to specify a file name and path for the next data 
set. Recording can be started and stopped from this window or set to stop after a 
specified duration. 

File Options: Select sampling frequency of recorded data. 

File Name and Path: Browse to, or type in, the desired file name and path. 

Auto-Increment: Enable automatically incrementing the data file names with an 
appended numeral. 

File Specification: Choose between the different file specifications. It is advised 
to always use the most current specification. 

File Storage Options 

After opening the File Storage Window, options can be found under View menu.  

Enable Sync Pulse: Send a unique waveform pattern every 14 seconds and 
repeat patterns hourly.  

Invert Sync Pulse: Invert the high and low phases of the sync pulse. 

Remove Noise: Do not save waveforms classified as noise during spike sorting. 

Sync with NeuroMotive Recording: Enable syncing with the NeuroMotive video 
recording and tracking system. 

Split File Interval: Enter either a duration or file size limit for each file segment. If 
file size is specified, click on “Calculate Time” to automatically populate the 
“Estimated Time” field. 

 

 
Figure 34–2.x Interface 
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Digital Oscilloscope 

The digital oscilloscope can display and measure two input channels on screen at a 
resolution of 0.1 milliseconds per division. Signals can be viewed continuously or on a 
specified trigger. Frequency spectra can also be displayed. 

Channel Enable: Two channels may be viewed per instance of the oscilloscope. 

Channel Selection: Select any channel from the drop-down menu. 

Color Selection: Select a color for either trace. 

Settings: Open the properties window for the selected channel.  

Invert: Invert the trace for a given channel. 

Trace Amplitude: Modifying the sliders for each 
channel will change the signal amplitude. The top slider 
changes the range and the lower slider selects a value 
within the given range.  

Time/Frequency selection: Set the oscilloscope into 
time or frequency mode. 

 
Figure 35–Digital Oscillloscope View 

 
Figure 36–Trace Amplitude 
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Time Resolution: Modifying the sliders will change the time resolution of the trace. The 
upper sliders change the range of resolution and the lower slider is used to choose a 
value within the given range. 

If no continuous trace is visible on the oscilloscope, confirm that the channel of interest 
is being sampled from in the Analog Input Properties window. If no trace appears despite 
sampling from the channel there may be a compatibility issue with your graphics 
adapter. Please contact Blackrock at support@blackrockmicro.com. 

Trigger Type 

Different triggers can be used to position and display waveforms on the 
oscilloscope. 

Auto: Continuous signal will be displayed until the trace crosses the user defined 
trigger level.  When the trigger level is crossed, the trace will pause for two 
seconds, then resume until another triggering event occurs. 

Normal: The trace will freeze as soon as the trace crosses threshold until the 
trace crosses the trigger level again in which case the screen will update with the 
new trace. 

Single: A single trace is captured as soon as it crosses the trigger level. To 
capture another threshold-crossed trace click on Single again. 

Trigger Level: Trigger level can be entered in the field or by manually sliding the 
trigger line on the display. 

Assign a trigger delay: Adjust the trigger position on the time axis. At 0 delay, 
the trigger will be placed at the left edge of the screen and may not be visible. 
Set a negative value to push the trigger point to the right. 
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Digital Filter Editor 

The Digital Filter Editor can generate custom filters to be used in Central Suite. It 
requires the Matlab Compiler Runtime to be installed. Contact 
support@blackrockmicro.com for a copy of this software.  

Filter type and corner frequencies are defined in the Editing Tools section on the left side 
of the window. The stability of the filter is shown in the Filter Status section below. The 
Bode Plot and the Nyquist Plot of the designed filter are displayed. Once the filter 
parameters are set, click on Save to save the digital filter.  

  

 
Figure 37–Digital Filter Editor 
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Activity Map 

The activity map color codes the firing rate of neurons on a two-dimensional map. An 
electrode map file assigns each channel to a location. The spiking activity of each 
channel is binned and smoothed over a fixed time window of 20 milliseconds. Smoothing 
adds steps between events and non-events both between channels and over time. 

Maximum Scale Range: Set the maximum value of the color scale in spikes per 
second. 

Scale Eccentricity: Skews the mapping of spike rate to color towards high or low 
values. 

Time Constant: Set the time constant controlling activity decay. 

Pause: Pause the display until unchecked.  

Reset: Clear current activity data and refresh visualization.  

Load Map File: Load a map file to change the orientation of the display. 

Default Map File: Return to the default 16x8 grid map file.  

  
 
 
 

  

 
Figure 38–Activity Map 
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Signal-to-Noise Ratio 

Signal-to-Noise Ratio (SNR) displays the running amplitudes of the signal, noise, and 
signal-to-noise ratio for units on each channel. It also displays the signal-to-noise ratio 
as a function of time, which allows changes in signal quality to be monitored. This 
information can be saved as a tab-delimited text file and opened in Excel or a compatible 
program for further analysis. In the example below the SNR for elec11 unit 3 is 9.50 
meaning that the signal is 9.5 times bigger than the noise. 

Neural Modulation 

Neural Modulation displays a histogram of changes in firing frequency over time. The 
Modulation Index is the variance of the histogram entries and covers a range of 0 to 
12.0.  A range of 2 to 5 is considered normal when recording neural signals. 

 
Figure 39–Signal to Noise Ratio 

 

 
Figure 40–Neural Modulation 
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Impedance Tester 

Impedance Tester measures and reports electrode impedance on each channel. To 
function properly the impedance mode must be selected in Central, click Tools > Options 
> Auto Impedance Interface. Either mode begins by asking for array information, 
including the serial number, implantation date, type of sterilization and comments.   

Special equipment may be required for impedance measurements. Contact Blackrock 
Microsystems sales at sales@blackrockmicro.com for more information. 

  

 
Figure 41–Auto Impedance 
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Crosstalk 

The Crosstalk Diagnostic window compares each channel to identify cross correlation. 
The Crosstalk Diagnostic feature will display each channel as green, yellow, or red, 
indicating the amount of unique signal on each electrode.  

Green: No cross correlation to any other channel was found. 

Yellow: Possible cross correlation found. Examine signals closely to determine best use. 

Red: High levels of cross correlation found. Consider removing these channels from 
recordings. 

  

 
Figure 42–Crosstalk 
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N-Trode 

Multiple single channels can be linked into N-Trode channel groupings. These are user 
defined electrode subsets created to record signals from proximal regions when any 
single unit spike is detected within the N-Trode. N-Trodes allow for neural events 
detected on one channel within an N-Trode to force the creation of neural events on the 
other N-Trode channels. When an event is detected on a channel within an N-Trode, all 
other N-Trode channels record a neural event with the same timestamp, spike width 
samples, pre-threshold samples, and refractory period (see Global Settings). Central 
supports multiple N-Trode sets containing up to four electrodes each. Define N-Trode 
configurations in the Hardware Configuration window or within the N-Trode application 
window. 

Note: Spike sorting occurs on the N-Trode as a single entity. This causes neural events 
on all N-Trode channels to be subject to refractory periods caused by a neural event 
detected on any N-Trode channel. 

 N-Trode: Use the drop-down menu to select an N-Trode group.  

 Scroll: Use the arrows to scroll through N-Trodes. 

 N-Trode Properties: Define or modify an N-Trode group. 

 Channel Properties: Open the Analog Input Properties window for all channels in 
the selected N-Trode group. 

 
Figure 43–N-Trode Utility 
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 View Tool Tip: Display time and amplitude values at the cursor position. 

 Hide Continuous: Toggle the Continuous Data Display on the bottom of the window. 

 Broadcast Channel Selections: Duplicates channel selection on other instances of 
Central running on computers connected to the ethernet switch. 

Options…: See a list of keyboard and mouse commands to manipulate the N-Trode 
GUI. 

Spike Display 

Spike Threshold: Adjust the voltage threshold for spike detection on all 
channels. 

Clear: Clear the spike display. Automatic clearing will occur to maintain the 
number of spikes shown in the drop-down menu. 

Show Spikes: Select which spike units to display. 

Add Comment 

The Add Comment feature allows the user to add a timestamped text comment to the 
Neural Event file. Comments can be visualized in the Raster Plot view. When in the 
Raster Plot window or the Central Main Window, a comment time stamp is initiated by 
typing and completed when the <Enter> key is pressed. 

nPlay Server 

nPlay Server loads and replays recorded neural 
data in ‘.nsx’ or ‘.nev’ formats for viewing and 
analysis in Central. When playing back the 
continuous data files, the user can filter, sort 
spikes, and down sample. A Neural Signal 
Processor does not need to be connected to the 
PC to use this utility.  

 

 
Figure 44–nPlay Server 
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Spike Sorting 

The Central software offers three automatic and manual methods for real-time spike 
sorting.  

Histogram Peak Count (Automatic) 

1. Open the Hardware Configuration window and select channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose Histogram Peak Count from the spike-sorting drop down menu. 
4. Click OK. 
5. In Central, click Tools > Rebuild Spike Sorting. This step may take a few 

minutes and must be repeated for each experimental session. Each time 
the sorting is rebuilt, new classifications are calculated based on current 
data. 
Note: To save Histogram Peak Counts sorting rules in Central, click File > 
Save Sorting Rules…. To load Histogram Peak Counts sorting rules, click 
File > Load Sorting Rules…. 

Hoops (Manual) 

1. Open the Hardware Configuration window and select channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “Hoops” from the spike-sorting drop down menu. 
4. Open Single Neural Channel and select the desired channel. 
5. Make sure the view classification icon is pressed down so you can see 

the units window.  
6. Click on the define button for a unit. A series of colored boxes will appear 

on the spike panel in the lower right corner.  
7. Drag each colored box out of its place and an amplitude band will appear. 
8. Place the band so that it intersects spikes to be classified in this unit. 

 
Figure 45–PCA Space 

 
Figure 46–Sorted Spikes 
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9. Four bands may be placed for each unit classification. 
10. Five individual units may be defined on each channel. 

Note: To save Hoops sorting rules in Central, click File > Save System 
Settings…. To load Hoops sorting rules, click File > Load System 
Settings…. 

Manual PCA 

1. Open the Hardware Configuration window and select channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “Manual PCA” from the spike sorting drop down menu. 
4. Open Single Neural Channel and select the desired channel. 
5. Make sure the unit icon is pressed down so you can see the units 

window. 
6. Click on the Feature tab. 

7. Click on Build PCA. By default the program needs 250 waveforms to build 
the PCA basis vectors. The time required to record 250 waveforms will 
depend on your spike rates and may take several minutes. You can 
modify the number of waveforms used in Hardware Configuration > Spike 
Sorting. 

8. Click the Define button for your first unit. 
9. Hold down the <Control> key and draw a line around a given cluster. The 

program will automatically create an ellipsoid around the cluster. Repeat 
this process for all the other units and channels. 
Note: To save Manual PCA sorting rules in Central, click on File > Save 
System Settings…. To load Manual PCA sorting rules, click File > Load 
System Settings…. To save PCA basis vectors, click File > Save PCA 
Basis…. To load PCA basis vectors, click File > Load PCA Basis…. 

 
Figure 47–PCA Space 
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k-means PCA 

1. Open the Hardware Configuration window and select one channels of 
interest. Multiple channels may be selected and sorted at once.  

2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “k-means PCA” from the spike sorting drop down menu. 
4. From the Central Suite main window select Tools > Auto Spike Sorting 

Method > All PCA Spike Sorting to begin the sorting process on all 
channels previously selected. 

5. Open Single Neural Channel and select the channel of interest from the 
drop-down menu. 

6. Make sure the unit icon is pressed down so you can see the units 
window. 

7. Click on the Feature tab. 

8. Click on Build PCA. By default the program needs 250 waveforms to build 
the PCA basis vectors. The time required to record 250 waveforms will 
depend on your spike rates and may take several minutes. You can 
modify the number of waveforms used in Hardware Configuration > Spike 
Sorting. 

9. Wait for feature points to be generated. Clustering accuracy will improve 
as the number of feature points increases. 

10. Click on the k-means button to define separate groups. 
Note: To save k-means PCA sorting rules in Central, click File > Save 
System Settings…. To load k-means PCA sorting rules, click File > Load 
System Settings…. To save PCA basis vectors, click File > Save PCA 
Basis…. To load PCA basis vectors, click File > Load PCA Basis…. 

 
Figure 48–PCA Basis Waveforms 
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DBSCAN PCA 

1. Open Hardware Configuration window and select the channels of interest. 
2. Right click and choose Properties or click on the “Properties” icon. 
3. Choose “DBSCAN PCA” from the spike sorting drop down menu. 
4. Open Single Neural Channel and select the channel of interest from the 

drop-down menu. 
5. Make sure the unit icon is pressed down so you can see the units 

window. 
6. Click on the Feature tab. 
7. Click on Build PCA. By default the program needs 250 waveforms to build 

the PCA basis vectors. The time required to record 250 waveforms will 
depend on your spike rates and may take several minutes. You can 
modify the number of waveforms used in Hardware Configuration > Spike 
Sorting. 

8. Wait for feature points to be generated. Clustering accuracy will improve 
as the number of feature points increases. 

9. Click on the DBSCAN button. 
Note: To save DBSCAN PCA sorting rules in Central, click File > Save 
System Settings…. To load DBSCAN PCA sorting rules, click File > Load 
System Settings…. To save PCA basis vectors, click File > Save PCA 
Basis…. To load PCA basis vectors, click File > Load PCA Basis…. 

How to Use Adaptive Filtering 

Adaptive filtering can be used to remove a known noise signal from neural data. 
Common noise sources include experimental monitors, subject reward systems, and 
equipment racks.  Identify the potential external noise source and connect it to the NSP 
using an analog input BNC connector. 

1. Plug the peripheral noise source into an analog input channel. 
2. Open Hardware Configuration > Adaptive Filtering. 
3. Right click the channel icon and select properties. 
4. Select one or two channel operation. 
5. Select the analog inputs used for the noise sources as reference channels. 

Create a Digital Filter 

Central Suite includes preset high pass, low pass and band pass filters. Filter 
parameters can be viewed in Hardware Configuration > Settings > Filters. The Digital 
Filter Editor allows you to construct custom filters.  

1. Open Central. 
2. Click on Digital Filter Editor. This tool requires MATLAB Compiler Run-time which 

is available on the Central Software Suite Installation CD and 
www.blackrockmicro.com 

3. Choose a filter type and the corner frequencies desired. If the filter is unstable 
the filter design tool will warn you and suggest ways to make the filter more 
stable. 
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4. Save the filter in a known location and exit the Digital Filter Editor. 
5. In Central, click on File > Load Digital Filters. 
6. Select up to four custom filters in the loading dialog.   
7. All newly added filters will be available in the drop-down menu under Hardware 

Configuration for analog inputs. 

Renaming Multiple Channels 

Central has a built-in automatic channel naming scheme with several parameters.  

1. Open Hardware Configuration. 
2. Select non-contiguous channels by 

holding down <Control> while selecting 
or select a range of channels by holding 
down the <Shift> key and clicking the 
upper and lower bounds of your 
selection.  

3. Right click and choose Properties. 
Alternatively, you can click on the 
“Properties” icon in the toolbar. 

4. Click the Edit button next to Label. 
5. Enter a label prefix you want across all 

selected channels. 
6. Choose a numbering scheme to be 

applied to each file after the prefix: 
a. Use current numbering: Maintain current channel numbering. 
b. Number channels sequentially starting at: Increment numbering from the 

start value by adding one to each additional channel. 
c. Number using channel ID: Number with the channel ID value going from 1 

to 128. 
d. Use terminal numbering: Number with the pin and bank value of the 

channel location on the front-end amplifier. 
 

  

 
Figure 49–Label Options 
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Remotely Control Data Recording 

Central software can be configured to start and stop recording when triggered by a 
digital input coming from other hardware, such as a behavioral control system. When 
using the TOC file format, the recording can be remotely started, stopped, resumed, or a 
new session can be initiated. When using the2.x file format, the recording can be 
remotely started, stopped, paused, and resumed. To setup remote recording using the 
DB-9 serial port or DB-37 digital input port do the following: 

1. Open the File Storage app, check the Remote Recording box, and click Setup. 
2. Select Digital Bit Input for any of the four remotely controllable tasks. 
3. On the second column choose a bit to be used for this function. 
4. On the third column choose high or low for triggering. 

For example, to remotely begin recording when digital bit 3 on the digital input port is set 
high, configure as shown below. 

Visualize an Input Channel on the Digital 
Oscilloscope 

The Digital Oscilloscope enables you to visualize two channels at high resolution. 
Setting a trigger can improve visualization of signals. To setup the oscilloscope, follow 
the instructions below.   

1. Open Central and in the main window click the Oscilloscope. 
2. Enable Trace 1 and/or Trace 2. 
3. Select a channel for each trace from the drop-down menu. 
4. Click on Settings to verify all channel settings. Make sure a sampling rate is 

selected for the given channel. If <none> is selected for sampling rate then a 
trace will not appear in the Oscilloscope. 

5. Set the amplitude of each trace by changing the slider bar for each channel. The 
upper slider modifies the range of values and the lower slider selects a value 
within the selected range. The units are µV/division.  

6. Move the trace location up or down by dragging the small triangle on the left of 
the trace. 

7. Set the time resolution by changing the resolution slider bar. The upper slider 
modifies the range of values and the lower slider selects a value within the 
selected range. The highest resolution is 0.1 milliseconds.  

8. A trigger can be set for the traces.  
a. Choose a channel source for the trigger. 
b. You can set the trigger level by entering a voltage value in the field or by 

sliding the trigger line up and down on the display. 

 
Figure 50–Example Settings for Remote Recording 
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c. Assign a trigger delay. At a default of zero, the trigger will be placed at the left 
edge of the screen and may not be visible. Negative values move the trigger 
to the right. 

9. Select a trigger type of Single, Normal, or Auto. 
a. Auto: Continuous signal will be displayed until the trace crosses the user 

defined trigger level.  When the trigger level is crossed, the trace will pause 
for two seconds, then resume until another triggering event occurs. 

b. Normal: The trace will freeze as soon as the trace crosses threshold until the 
trace crosses the trigger level again in which case the screen will update. 

c. Single: A single trace is captured as soon as it crosses the trigger level. To 
capture another threshold-crossed trace click on Single again. 

Configure Raster Plot  

The Raster Plot can display the occurrence of spike events or continuous signals for 
many channels over time. The plot can be configured to match your experimental setup. 

1. Begin by removing all channels from the display using the  clear all button. 

2. Open the  choose channels display and select the channels of interest.  

3. Use the  move buttons to order the selected channels. 

4. All channels can be  split into component channels. This will display a line for 
each classified spike unit as well as a continuous signal trace 

5.  Delete any unwanted channel components. 

6.  Resize channels of interest. It is often helpful to increase the size of 
continuous data traces. 

7. Adjust the  seconds per division of the markers on the plot. 

8.  Change the font size for channel labels to be easily read.  

For an explanation of further Raster Plot functionality see Page 44. 
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Figure 51–Sample CMP File 

 

Change Electrode Map (Create a Map File) 

It is possible to re-arrange the electrode positions on Spike Panel and Activity Map. A 
plain text “map” file contains the location assignments of each channel. A sample map 
file is included below. 
 

// 8-Channel NSP map file demo 

// 

// Data is as follows, 'C(olumn) r(ow) b e l' 

//   c - 0 based column from left to right 

//   r - 0 based row from bottom up 

//   b - bank name - values can be A, B, C, or D 

//   l - label used to rename channels in Central 

// 

// Comments begin with '//' 

// First non-comment line is the Mapfile description 

// 

8 Channel NSP mapping 

0 1 A 4 elec08 

1 0 A 8 elec07 

2 1 A 3 elec06 

3 0 A 6 elec05 

0 0 A 5 elec01 

1 1 A 2 elec02 

2 0 A 7 elec03 

3 1 A 1 elec04 
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The map file contains five columns. The first column indicates the location of the spike 
window on the x-axis. The second column indicates the location of the spike panel on 
the y-axis. Point 0,0 is on the lower left corner of the screen. The third column indicates 
the bank the physical channel is located on (A, B, C, or D) and the fourth column 
indicates the bank pin the channel is connected to. The fifth column is optional and 
defines the label for the channel. 

In the example above, the first line indicates that the channel on bank A pin 4 is named 
elec08 and it’s located on the 1st column from left (0) and the 2nd row from the bottom 
(1). The last line indicates that the channel on bank A pin 1 (channel 1) is named elec04 
and it should be placed on the 4th column (3) from left and the 2nd row from bottom (1). 
Location positions start from 0. Any line that starts with “//” will be used as comment and 
will be ignored. The first line after the last // line is the name of the map file as referenced 
in the apps and will also be ignored. 

 
Figure 52–Sample Spike Panel 

 



 
 
 
 

Revision 6.00 / LB-0323 – NeuroPort Biopotential Signal Processing System IFU  
© 2021 Blackrock Microsystems, LLC 

72 

Setup 

Hardware Setup 

Digital NeuroPort System 

1. Remove the NSP and Digital Hub from the shipping boxes.  
2. Attach the NSP rack-mount brackets to install it in an equipment rack, or 

rubber feet to place it on a table.  
3. Plug in the NSP and Digital Hub to electrical outlets.  
4. Connect one end of the fiber-optic cable to the NSP and the other end to 

the Digital Hub. 
5. Attach headstages to the Digital Hub and connect them to electrodes. 

Make sure the connections are secure. 
Warning: Only connect headstages to the Digital Hub. 

6. Turn on the NSP and Digital Hub. 

7. The LED near the fiberoptic port of the NSP and Digital Hub should turn 
green. 
Note: Maximum channel capacity setup may include up to four NeuroPlex 
E headstages, four Digital Hubs, and two 256ch NSPs. 

NeuroPort System 

1. Remove the NSP, Amplifier and APS from the shipping boxes. 
2. Attach the NSP rack-mount brackets to install it in an equipment rack, or 

rubber feet to place it on a table.  
3. Plug in the NSP and APS to electrical outlets.  
4. Connect one end of the APS cable to the APS and the other end to the 

Amplifier. The cable needs to click and lock in place. 
5. Connect one end of the fiber-optic cable to the NSP and the other end to 

the Amplifier. 
6. Attach optional headstages to the amplifier inputs and connect them to 

electrodes. 
7. Turn on the NSP and APS 
8. The LED on the APS, Amplifier, and the NSP should turn green. 
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Software Setup 

Installing Central Software Suite 

1. Uninstall any previously existing versions of Central Suite through 
Programs and Features in Windows Control Panel. 

2. Run the Central Suite installer (.msi) from the installation CD or 
www.blackrockmicro.com 

3. Install the MATLAB Compiler Runtime from the supplied installation CD or 
www.blackrockmicro.com 

Blackrock recommends that a dedicated PC be used to run Central. Refrain from 
installing any additional software or connecting the PC to the internet. Make sure 
to disable Windows auto-updates. 

Setting up the Ethernet Connection 

Note: If you purchased the NeuroPort Host PC, the Ethernet card is pre-installed 
and configured in your PC. 

1. Once installed, the card needs to be configured to connect to the NSP.  
2. Click on Start and search for “View Network Connections”. 
3. Right click on the correct Ethernet Adaptor (usually, Local Area 

Connection) and click on Properties. 
4. Uncheck all services except for Internet Protocol (TCP/IP) or Internet 

Protocol Version 4 (TCP/IPv4). 
5. Click on Internet Protocol (TCP/IP) and click on Properties 
6. For IP Address enter 192.168.137.1, for Subnet Mask enter 

255.255.255.0 and leave the rest blank.  
7. Click on OK to save changes. 

 
 

 
 

 
Figure 53–Network Connections Window 
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Note: Up to 16 PCs can be connected to the same NSP using a business class 
1-Gbps network switch with QoS feature. For other PCs connected using a 
network switch, IP addresses should increment, such as 192.168.137.2, 
192.168.137.3, etc. 

Note: For your reference, the NSP’s IP address is 192.168.137.128. 

  

 
 

Figure 54–Local Area Connections Properties 

 

 
 

Figure 55–IPv4 Properties 
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Sterilization, Cleaning, Maintenance, and 
Disposal 

Sterilization and Cleaning 

The only components of the NeuroPort System that are provided sterile are the Patient 
Cable, NeuroPlex E and Digital Data Cables. The remaining components cannot be 
sterilized, but devices may be cleaned by wiping surfaces. To clean the NeuroPort 
System, the exterior of NeuroPort System devices may be wiped down water or 
isopropyl alcohol. Sanitizing wipes should not be used on the Digital Hub or other plastic 
components of the system. Dust and debris on the exterior connectors/ports may be 
removed with compressed air. 

Maintenance 

The system does not require any scheduled maintenance or calibration. Maintenance on 
interior components of the NeuroPort System should only be carried out by or on the 
instructions of an authorized Blackrock Microsystems representative. For issues with the 
system, see the troubleshooting section and/or RMA sections below.  

Disposal 

All devices, both used and unused, should not be disposed with household waste. 
Return to a recycling point for electric and electronic devices. 

Magnetic Resonance 
The NeuroPort System has not been evaluated for safety and compatibility in the MR 
environment. The NeuroPort System has not been tested for heating, migration, or image 
artifact in the MR environment. For this reason, the device is not considered safe to use in an 
MR environment.  
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Troubleshooting/Error Messages 

Problem Symptom Failure Potential fix 

No data 
displayed 

Yellow LED on 
Amplifier or Digital 
Hub 

 

System not 
receiving valid 
packets  

If NeuroPort is turned on and 
running but there is no apparent 
activity on any of the channels from 
an implant or from the simulator, 
verify the following: 

Verify all cables are securely 
plugged in. 

Open Central.exe and verify that 
packets are being received from 
the NeuroPort system. If the PC is 
not receiving packets from the 
NeuroPort system, see 
troubleshooting section “Lost 
Packet Error Notification” above. 

Verify that the fiber optic data link 
between the Amplifier/Digital Hub 
and the NeuroPort NSP is plugged 
in and that the green light next to 
the fiber optic data port on the NSP 
is illuminated. If the light is red, 
there is no fiber optic link present. 
Check the LED next to the fiber 
optic port on the back of the 
Amplifier or front of the Digital Hub 
to verify that it has power.  

Standard System 

If the LED is not illuminated, check 
the APS and verify that it is turned 
on and not in standby mode.  

Digital System 

Possible compatibility issue or 
damaged cable – replace cable 
otherwise contact 
support@blackrockmicro.com with 
serial number of Digital Hub and 
headstages and cable lengths 
 
 
 
 

mailto:support@blackrockmicro.com
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Problem Symptom Failure Potential fix 

Noise Poor Signal to 
Noise Ratio or 
Excess High 
Frequency Signal 

Uncontrolled 
noise sources 
and/or poor 
referencing or 
grounding 
scheme 

The system is sensitive to 
electromagnetic signals. It is 
designed to detect microvolt level 
signals.  

Cable arrangement and external 
noise source management are 
important.  

Avoid allowing cables of the 
system near other power cables, 
monitors, light sources, or other 
electrical equipment. Change 
which electrode is used as 
reference to better remove 
common noise or use noise 
cancellation in Central to remove 
noise from the recording. 

System Not 
Turning On 

No Lights on LCD 
of Neural Signal 
Processor 

Secondary 
Power Supply 
Switch is Off 

Verify that the NeuroPort system is 
plugged into a working outlet, and 
verify that all power cords are 
plugged into the NeuroPort. 

Verify the position of the power 
switch in the rear of the Neural 
Signal Processor is ON. If the 
power switch is in the ON position, 
turn it to the off position then wait 
at least five seconds before turning 
the NSP back on. (It is 
recommended that when restarting 
the NSP, always wait at least five 
seconds before turning the unit 
back on. This will ensure a proper 
system reset.) 

NSP Is Stuck in 
Initializing 

LCD of Neural 
Signal Processor 
Says “Initializing” 
for more than 2 
minutes and/or 
Central gives an 
error that says 
“The System is 
Initializing” 

Poor Software 
Initialization or 
Disconnected 
Cables within 
the Neural 
Signal 
Processor 

Try turning the NSP OFF using the 
rear power switch. Toggle the front 
power switch 5 times on and off. 
Wait 5 minutes. Turn the NSP back 
on. If the NSP is still not initializing 
then contact 
support@blackrockmicro.com  

 

 

mailto:support@blackrockmicro.com
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Problem Symptom Failure Potential fix 

Instrument 
Network Has 
Failed 

Error Message In 
Central and No 
Data 

Disconnected 
Ethernet Cable 
or Powered Off 
Device 

Check that the NSP is powered on 
and that the ethernet cable is 
connected. Check that the ethernet 
switch is powered on if it is being 
used. 

Data Recording 
Restarted 

Error Message 
from Central 

High Data Rate High data rates or busy hard drives 
can cause this error. Disable non-
essential applications such 
asDefender, system sounds, and 
Automatic Updates. Ensure hard 
drives are not near full, defragment 
hard drives, or utilize hard drives 
with faster write speeds, such as 
solid state drives. Alternatively, 
reduce the number of continuously 
sampled channels. 

Warning: Disabling Firewalls and 
Anti-Virus software can leave your 
system vulnerable to cyberattacks. 

Packets Lost Error Message 
from Central 
Indicating Lost 
Packets 

Poor Ethernet 
Communication 
or Excess CPU 
load 

Check that the ethernet cable is 
CAT6. Ensure that the ethernet 
port is capable of gigabit operation. 
Check ethernet connection and 
reduce CPU load. Allow Central to 
communicate through the firewall. 

 

Central error messages and common solutions are listed here. Once these steps are exhausted 
please contact Blackrock Support.  

Files are currently being recorded.  Do you want to stop recording and close the app? 

The user has attempted to close the Central Main Window while recording is ongoing. To avoid 
this error, always stop recording before attempting to close the software.  

Unable to allocate shared Memory 

Both Central Software Suite and another utility have attempted to connect to the NSP via UDP. 
To remedy this, shut down any utilities, such as cbMEX, or cbSDK, that may be attempting to 
communicate with the NSP.  

Recording is currently blocked by another utility.  Please close that utility and try again. 

A utility within the Central Suite is interfering with recording. Check to see if impedance mode is 
running. If not, restart your Host PC and try recording again.  

Unable to open the Central Application! 

An error has occurred within the Central Main Window startup. Restart your Host PC and 
reinstall Central Suite.  
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The basis vectors have not yet been calculated for this channel. Please Build PCA then 
retry 

The user has attempted to save spike sorting settings before generating sorting rules. Define 
spike sorting rules in the Single Channel Viewer Window before saving.   

There may not be enough data points to effectively calculate the ellipsoids. Would you 
like to continue? 

An insufficient number of detected spikes have been recorded to create ellipsoid groupings on 
the PCA space. Wait until more spikes are recorded before attempting to define ellipsoids. 
Proceeding with fewer spike events is possible but may not produce accurate unit definitions.  

Unable to Open Instrument Network 

OR 

It appears that the instrument network has failed. 

Central cannot communicate with the NSP. If this occurs, confirm that: 

1. The NSP is powered on. 
2. An ethernet cable connects the NSP and the Host PC. 
3. If a switch is used, it is connected correctly and powered on. 
4. The Ethernet port has been configured as described on Page 69. 

Once confirmed, restart the NSP and Host PC. 

Network packets have been lost between the NSP and this PC. 

This is most likely caused by the system load being higher than 8 MB/s. 

OR 

Network packets have been lost between the PC and the instrument  

These errors occur when the Central Software Suite intermittently fails to communicate with the 
NSP over ethernet. To remedy this, confirm that: 

1. The NSP is still powered on, and is connected to the Host PC with an ethernet cable.  
2. No other applications are consuming significant system resources. 

If so, attempt the following: 

1. Disable Windows Firewall, Defender, Restore, Sound, Automatic Update, System 
Notifications, and other Ethernet ports. 
Warning: Disabling Firewalls and Anti-Virus software can leave your system vulnerable 
to cyberattacks. 

2. Uninstall anti-virus and any unnecessary software.  

The system is initializing, please wait. 

If the system doesn't respond, click the Reset NSP button below. 

This error occurs when the Central Software Suite recognizes an NSP that is not initialized. 
When this error message occurs, confirm that the NSP screen also shows the “Initializing” 
message. If so, wait for up to a minute before resetting the NSP. Attempt to reset with the 
software button included in the error message before doing a hardware reset with the switch on 
the front of the NSP.  

  



 
 
 
 

Revision 6.00 / LB-0323 – NeuroPort Biopotential Signal Processing System IFU  
© 2021 Blackrock Microsystems, LLC 

80 

Network packets have been lost between the NSP and this PC. 

This is caused by the system load being higher than 12 MB/s 

This error occurs when data is possibly lost within the NSP and is not sent to the PC. To remedy 
this error, confirm that your NSP is running the latest firmware available in the Software 
Downloads section of www.blackrockmicro.com.  

Data Recording Restarted. 

The data load to the PC is extremely high and data storage has been restarted. Please 
reduce the burden on your PC and restart data collection. 

This error occurs periodically in very long duration recordings. To remedy this, attempt the 
following: 

1. Disable Windows Firewall, Defender, Restore, Sound, Automatic Update, System 
Notifications, and other Ethernet ports. 

2. Uninstall anti-virus and any unnecessary software.  
3. Close any other active applications. 
4. Reduce the number and rate of continuously sampled channels. 
5. Consider a faster PC or hard drive, such as a solid state drive. 

 

Return Merchandise Authorization 
In the unlikely event that your NeuroPort system needs to be returned to Blackrock for repair or 
maintenance, do not send any equipment back without a Return Merchandise Authorization 
Number. An RMA number will be issued to you by a Blackrock representative. If you need to 
obtain an RMA number, you may contact a support representative at +1 (801) 582-5533 or via 
email support@blackrockmicro.com. 

Once an RMA number has been issued, it is important to safely pack the returned item for 
shipping back to Blackrock. It is preferred that you save the original boxes and packing 
materials that your NeuroPort system arrived in for return shipment. Please address the 
package as follows: 

 
Blackrock Microsystems 
ATTN: RMA # 
630 S. Komas Drive, Suite 200 
Salt Lake City, UT 84108 USA 
Tel: +1 (801) 582-5533 

  

mailto:support@blackrockmicro.com
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Warranty 
Blackrock Microsystems (“Blackrock”) warrants its products are free from defects in materials 
and manufacturing for a period of one year from the date of shipment.  At its option, Blackrock 
will repair or replace any product that does not comply with this warranty. This warranty is 
voided by: (1) any modification or attempted modification to the product done by anyone other 
than an authorized Blackrock employee; (2) any abuse, negligent handling or misapplication of 
the product; or (3) any sale or other transfer of the product by the original purchaser.  

Except for the warranty set forth in the preceding paragraph, Blackrock provides no warranties 
of any kind, either express or implied, by fact or law, and hereby disclaims all other warranties, 
including without limitation the implied warranties of merchantability, fitness for a particular 
purpose, and non-infringement of third-party patent or other intellectual property rights.  

Blackrock shall not be liable for special, indirect, incidental, punitive, exemplary or consequential 
damages (including without limitation, damages resulting from loss of use, loss of profits, 
interruption or loss of business or other economic loss) arising out of non-compliance with any 
warranty.  Blackrock’s entire liability shall be limited to providing the remedy set forth in the 
preceding paragraph. 
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Support 
Blackrock prides itself in its customer support. For additional information on this product or any 
of our products, you can contact our Support team through the contact information below: 

 
Manuals, Software Downloads, and Application Notes 
www.blackrockmicro.com/technical-support 

Complaints 

When filing a complaint, please provide the product description, product number, 
software version, lot number, complainant's name and address, and the nature of the 
complaint. 

 
Issues or Questions 
www.blackrockmicro.com/technical-support 
support@blackrockmicro.com 

U.S.: +1 (801) 582-5533 
 

Notice to the user and/or patient that any serious incident that has occurred in relation to the 
device should be reported to the manufacturer. 

CAUTION  

Federal law restricts this device to sale by or on the order of a physician. 

   
 

 
 

 

This device complies with part 18 of the FCC rules 

http://www.blackrockmicro.com/technical-support
http://www.blackrockmicro.com/technical-support
mailto:support@blackrockmicro.com

